delivolicita

Ajustes tras instalar Debian «Stable» en un Dell XPS M1330

Tras instalar la versión «Stable» de Debian en un Dell XPS M1330 me he encontrado con varios problemas por resolver, principalmente con las conexiones de red. No me ha sorprendido demasiado, estaba avisado de que la rama estable es muy robusta pero también algo limitada detectando hardware.

Red cableada no gestionada. La conexión ethernet funciona correctamente pero en el area de notificación aparece sin conexión (icono con forma de X). Para solucionarlo editamos el fichero /etc/network/interfaces para que, tal y como indican en los foros, comentemos las entradas que hacen referencia a eth0, y así networkmanager pueda gestionar el interfaz (por lo visto no gestiona las redes que están definidas en ese archivo).

  • Desde un terminal de root editamos el archivo interfaces

    sudo gedit /etc/network/interfaces

    y comentamos las líneas que hacen referencia a eth0, quedandonos:
    # The loopback network interfaces
    auto lo
    iface lo inet loopback
    # The primary network interface
    #auto eth0
    #iface eth0 inet dhcp

  • Reiniciamos network-manager y listo./etc/init.d/network-manager stop
    /etc/init.d/network-manager start

Tarjeta WiFi no detectada. Instalamos el driver iwlegacy que soporta el chipset Intel 4965 AGN que traen los Dell XPS M1330.

  • Añadimos el repositorio non-free, actualizamos e instalamos:
    $ echo "deb http://http.debian.net/debian/ wheezy main contrib non-free" >> /etc/apt/sources.list
    $ apt-get update && apt-get install firmware-iwlwifi
  • Y por último cómo iwlegacy se carga automáticamente para los dispositivos soportados, añadimos los módulos para acceder al firmware instalado.

    $ modprobe -r iwl4965
    $ modprobe iwl4965

Comentar

Plantilla desarrollada y mantenida por la Sociedad de las Indias Electrónicas, síguelos diariamente en El Correo de las Indias